Started 3 months agoJune 01, 2026Lasted about 3 hoursJune 01, 20267:2410:38UTC
Affected
CDN
Major outage from 7:24 AM to 10:38 AM
Optimizer
Major outage from 7:24 AM to 10:38 AM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Investigating
UTC
Investigating
UTC
We're currently investigating an issue causing the Optimizer to serve a number of 5XX errors. We're investigating this as a matter of priority and we will provide updates here as soon as we can.