Scheduled for March 11, 2025 at 3:00 PM – 3:53 PM
Affects
Billing Portal [portal.noxity.io]
Under maintenance from 3:00 PM to 3:53 PM
Domain Registrations
Under maintenance from 3:00 PM to 3:53 PM
System / API
Under maintenance from 3:00 PM to 3:53 PM
Registries
Under maintenance from 3:00 PM to 3:53 PM
Completed
March 11, 2025 at 3:53 PMCompleted
March 11, 2025 at 3:53 PMMaintenance has been completed successfully. In the following update (most likely tomorrow), we will also update the front-facing order forms to correctly reflect some custom requirements on certain TLDs.
In progress
March 11, 2025 at 3:00 PMIn progress
March 11, 2025 at 3:00 PMMaintenance is now in progress
Planned
March 11, 2025 at 3:00 PMPlanned
March 11, 2025 at 3:00 PMFrom 15:00 UTC until the end of the day, we will be performing upgrades to a domain registration system. During this time, you may notice errors or no information for any domain actions under your account. This includes registrations, renewals, and general information. We apologize for the inconvenience. Once the maintenance is completed, we will post an update.